Option A方案,要点是,PE与ASBR之间建立MP-BGP关系,PE-P-ASBR使用MPLS LDP传输公网标签,ASBR与ASBR之间建立vpn-instance的EBGP邻居来延续私网标签的传输,另外AR1与AR8同属一个AS,由于AS的EBGP防环策略,需要配置allow-as-loop命令来指定重复次数,不指定为1
由于AS200与AS100配置镜像,只放PE1与ASBR1配置
PE1:
#
sysname AR2-PE1
#
ip vpn-instance PE1
ipv4-family
route-distinguisher 100:1
vpn-target 100:200 export-extcommunity
vpn-target 100:200 import-extcommunity
#
mpls lsr-id 2.2.2.2
mpls
#
mpls ldp
#
interface GigabitEthernet0/0/0
ip binding vpn-instance PE1
ip address 10.0.12.2 255.255.255.0
#
interface GigabitEthernet0/0/1
ip address 10.0.23.2 255.255.255.0
mpls
mpls ldp
#
interface LoopBack0
ip address 2.2.2.2 255.255.255.255
#
bgp 100
peer 4.4.4.4 as-number 100
peer 4.4.4.4 connect-interface LoopBack0
#
ipv4-family unicast
undo synchronization
peer 4.4.4.4 enable
#
ipv4-family vpnv4
policy vpn-target
peer 4.4.4.4 enable
#
ipv4-family vpn-instance PE1
peer 10.0.12.1 as-number 64512
#
ospf 1
area 0.0.0.0
network 2.2.2.2 0.0.0.0
network 10.0.23.2 0.0.0.0
#
return
ASBR1:
#
sysname AR4-ASBR1
#
ip vpn-instance ASBR1
ipv4-family
route-distinguisher 100:4
vpn-target 100:200 export-extcommunity
vpn-target 100:200 import-extcommunity
#
mpls lsr-id 4.4.4.4
mpls
#
mpls ldp
#
interface GigabitEthernet0/0/0
ip address 10.0.34.4 255.255.255.0
mpls
mpls ldp
#
interface GigabitEthernet0/0/1
ip binding vpn-instance ASBR1
ip address 10.0.45.4 255.255.255.0
#
interface LoopBack0
ip address 4.4.4.4 255.255.255.255
#
bgp 100
peer 2.2.2.2 as-number 100
peer 2.2.2.2 connect-interface LoopBack0
#
ipv4-family unicast
undo synchronization
peer 2.2.2.2 enable
#
ipv4-family vpnv4
policy vpn-target
peer 2.2.2.2 enable
#
ipv4-family vpn-instance ASBR1
peer 10.0.45.5 as-number 200
#
ospf 1
area 0.0.0.0
network 4.4.4.4 0.0.0.0
network 10.0.34.4 0.0.0.0
#
return